Schedulr - Past Months May Appear Blank – Incident details

All systems operational

Past Months May Appear Blank

Resolved
Degraded performance
Started about 6 hours agoLasted about 6 hours

Affected

schedulr

Degraded performance from 4:02 PM to 9:48 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved and will be released in v1.14.1 on Thursday 18th June.

  • Identified
    Identified

    We have identified why older calendar months (for example April) can appear empty in Schedulr even though your events are still saved and may still show in Apple Calendar on the Schedulr calendar. The app currently only loads events from the last 30 days into the calendar view, so past months look blank. This is not caused by data deletion — your events are safe. A fix is in progress (OPS-6).

  • Investigating
    Investigating

    We are aware that older calendar months (for example April) may appear empty in Schedulr even though events still exist in your account and may still show in Apple Calendar on the Schedulr calendar. This is not caused by data deletion. We are investigating a display issue where the app only loads events from the last 30 days. Your events are safe in Schedulr. A fix is being tracked and we are currently investigating this incident.